Gallery Grabber QED Browser Extensions

The following Gallery Grabber browser extensions are currently available:

The browser extensions require Gallery Grabber QED 1.0 or later to work. Gallery Grabber QED 1.0 works on OS X 10.5 Leopard or later (including Snow Leopard).